Sage 50 Cloud (DE) - Degraded Performance
Incident Report for Sage
Resolved
There was no issue, disregard.
Posted Jan 12, 2023 - 20:59 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jan 12, 2023 - 20:54 UTC
This incident affected: Europe (Sage ERP (DE)).