The issue is resolved and the service is performing as expected.
Posted Aug 05, 2025 - 10:30 UTC
Identified
We have identified an issue where customers in South Africa are experiencing slowness when using the “List of Items” and “List of Functionalities” functionalities. We are working on fix to resolve the issue.
Posted Aug 05, 2025 - 09:38 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 05, 2025 - 09:30 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Accounting ZA).