Sage Business Cloud Payroll Professional - Operational

Incident Report for Sage

Resolved

The issue is resolved. Sage Business Cloud Payroll Professional continues available and performing as expected.
Posted Jan 24, 2024 - 16:00 UTC

Monitoring

Sage Business Cloud Payroll Professional is available and performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Jan 24, 2024 - 12:48 UTC

Update

Thank you for your patience as we work to resolve this issue.
Posted Jan 24, 2024 - 12:00 UTC

Update

We have identified an issue preventing customers in South Africa from accessing the service. Those who are already logged in, can still using the service as expected.
We are currently investigating.
Posted Jan 24, 2024 - 09:59 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jan 24, 2024 - 09:49 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Payroll Professional).