Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 18:00 UTC
Scheduled
Sage Business Cloud Accounting ZA will be undergoing maintenance on Friday, November 8th, 2024, for 12 hours, between 20:00 SAST and 08:00 SAST, on November 9th.
The service will be unavailable during this scheduled time.
We apologize for any inconvenience this may cause.
For further information, please click on this link.
Thank you. The Sage Team
Posted Oct 31, 2024 - 15:16 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Business Cloud Accounting ZA).