The issue is resolved and the service is available and performing as expected.
Posted Aug 03, 2026 - 16:45 UTC
Identified
Our third-party AccessPay has informed us that they are undergoing an emergency maintenance which may cause delays in transaction processing for customers in the UK,US and Canada. We are engaged and working with AccessPay to resolve the issue.
The affected service/product is: - Sage Intacct
Posted Aug 03, 2026 - 13:46 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 03, 2026 - 13:10 UTC
This incident affected: North America (Banking Service, Sage Intacct) and Europe (Banking Service, Sage Intacct).