Sage RTX (EU) - RTX

Incident Report for Sage

Resolved

The issue is now resolved. All services continue to perform as expected.
Posted Apr 24, 2025 - 09:22 UTC

Monitoring

Third-party, Revenue Online Service (ROS), has confirmed that the issue has been resolved. We can confirm that our customers are successfully submitting their PSR's to the revenue.

We will continue to monitor closely.
Posted Apr 23, 2025 - 12:19 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 23, 2025 - 11:55 UTC
This incident affected: Europe (Sage RTX (EU)).