Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 06, 2025 - 20:00 UTC
Scheduled
Online Bureau (UKI) will be undergoing maintenance on Thursday, February 6th, 2025, for 4 hours and 30 minutes, between 20:00 UTC and 00:30 UTC, on February 7th.
During this scheduled period of time Online Bureau (UKI) will be unavailable, and customers using the below services may be unable to access their payslips for few minutes: -Sage HR Global -Payroll Domain Services (UKI) - Employee Verification -Sage Business Cloud Payroll (UK)
We apologise for any inconvenience this may cause.
Thank you. The Sage Team
Posted Feb 05, 2025 - 13:18 UTC
This scheduled maintenance affected: Europe (Employee Verification (UK), Online Bureau (UKI), Sage Business Cloud Payroll, Sage HR), Middle East and Africa (Sage HR), and North America (Sage HR).