Sage Business Cloud Accounting (NA) - Major Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Feb 03, 2025 - 18:07 UTC
Update
We identified an issue preventing NA customers from accessing the application. We are currently investigating.
Posted Feb 03, 2025 - 17:33 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Feb 03, 2025 - 17:16 UTC
This incident affected: North America (Sage Business Cloud Accounting (NA)).