Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 28, 2025 - 01:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Thursday, August 28th, 2025, for 30 minutes, between 02:00 BST and 02:30 BST. (11:00 AEST and 11:30 AEST). (21:00 EDT and 21:30 EDT on Wednesday, August 27th).
The service may be unavailable during this period.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance le Mercredi 27 août 2025, pendant 30 minutes, entre 21:00 EDT et 21:30 EDT.
Le service pourrait ne pas être accessible pendant cette période.
Nous vous prions de nous excuser pour la gêne occasionnée.
Merci. L'équipe Sage
Posted Aug 22, 2025 - 19:29 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).