Sage 50 Cloud
Incident Report for Sage
Resolved
The incident is now resolved and the service continues to operate as expected.
Posted Apr 28, 2022 - 16:36 UTC
Monitoring
The service is now available and operating as expected. We are closely monitoring the service to avoid a reoccurrence.
Posted Apr 28, 2022 - 12:22 UTC
Investigating
We have identified an issue affecting Sage 50 cloud Accounts. Customers using an IE11 browser are receiving a maintenance page. We are currently investigating this issue.
Posted Apr 28, 2022 - 09:21 UTC
This incident affected: Europe (Europe).