Payments Out Service - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Jan 23, 2026 - 20:32 UTC

Identified

We have identified an issue where vendor payments are not processing through Edenred. We are currently investigating.
Posted Jan 23, 2026 - 15:18 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jan 23, 2026 - 15:02 UTC
This incident affected: North America (Payments Out Service).