Sage Intacct - Partial Outage

Incident Report for Sage

Resolved

We identified that a subset of customers in the US were unable to access the service.
The issue is now resolved and the service is available and performing as expected.
Posted Jul 01, 2025 - 23:20 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 01, 2025 - 23:05 UTC
This incident affected: North America (Sage Intacct).