Sage 50 - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Apr 08, 2025 - 17:22 UTC

Update

We have identified an issue where UKI customers get a blank screen when logging into Sage for Accountants/Client Management.
We are currently investigating.
Posted Apr 08, 2025 - 16:44 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 08, 2025 - 16:18 UTC
This incident affected: Europe (Sage 50).