Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2026 - 03:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Wednesday, March 18th, 2026, for 7 hours between 23:00 EDT and 06:00 EDT on March 19th. (03:00 UTC and 10:00 UTC on March 19th); (14:00 AEDT and 21:00 AEDT on March 19th).
The service may be unavailable during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance système importante le mercredi 18 mars 2026, pendant 7 heures, entre 23:00 EDT et 06:00 EDT le mars 19.
Le service peut être indisponible pendant cette période prévue.
Nous nous excusons pour les inconvénients que cela pourrait causer.
Merci. L'équipe Sage.
Posted Mar 17, 2026 - 17:25 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).