The issue is resolved and the service is available and performing as expected.
Posted Mar 16, 2026 - 10:01 UTC
Update
The access to help.fylehq.com has been restored and we continue working on the fix for the other 2 URLs.
We appreciate your patience
Posted Mar 16, 2026 - 09:25 UTC
Update
We have identified that customers globally are unable to access the following websites cards.fylehq.com / careers.fylehq.com / help.fylehq.com. Customers are being re-directed to a maintenance page for the 2 first ones, and to a "This Page isn´t working" error on the last one.
We are currently working on a fix for the issue.
Posted Mar 16, 2026 - 08:19 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 16, 2026 - 08:06 UTC
This incident affected: Asia Pacific (Sage Expense Management), North America (Sage Expense Management), and Europe (Sage Expense Management).