Sage People - Degraded Performance
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Jul 18, 2024 - 15:57 UTC
Identified
We identified an issue preventing customers from Europe from accessing the service and/or experiencing slow performance when accessing the service. We are engaged and working with third party vendor, Salesforce to resolve this issue.
Posted Jul 18, 2024 - 14:37 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 18, 2024 - 14:14 UTC
This incident affected: Europe (Sage People).