Sage Business Cloud Self Service - Partial Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Jul 26, 2024 - 08:45 UTC
Update
We identified and issue preventing a small subset of customers in South Africa from accessing the service. When customers try to login, they are redirected back to the login screen. We are currently investigating.
Posted Jul 26, 2024 - 08:09 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 26, 2024 - 07:51 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Self Service).