Sage Self Service - Major Outage
Incident Report for Sage
Resolved
The issue has been identified and resolved.
Posted Nov 09, 2020 - 12:59 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Nov 09, 2020 - 12:39 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Self Service).