Sage Timeslips Go - Degraded Performance

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Aug 08, 2025 - 21:31 UTC

Update

We continue to work on a fix for the issue. We appreciate your patience as we work to resolve this issue.
Posted Aug 08, 2025 - 19:04 UTC

Identified

We have identified an issue preventing new customers and new users in North America from being onboarded to the product. We have identified the cause of the issue and are working on a fix.
Posted Aug 08, 2025 - 16:43 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 08, 2025 - 16:27 UTC
This incident affected: North America (Sage Timeslips Go).