The issue is resolved and the service is performing as expected.
Posted Apr 01, 2022 - 14:59 UTC
Update
As we are committed to providing our customers with the best experience, we are continuing to implement performance improvements to mitigate this issue.
Posted Apr 01, 2022 - 12:28 UTC
Identified
We have identified the cause of the issue and we are working on a fix. The issue is also impacting customers using Sage 200 and Sage Start.
Posted Apr 01, 2022 - 11:08 UTC
Update
We have identified an issue in Switzerland, preventing some customers using Sage50 to see their payslips. We are currently investigating.
Posted Apr 01, 2022 - 09:38 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.