Sage 50 Cloud (FR) - Partial Outage

Incident Report for Sage

Update

We are continuing to investigate. Thank you for your understanding as we work to resolve this issue.
Posted Jun 12, 2026 - 16:34 UTC

Update

We are continuing to investigate the cause of the issue. Thank you for your patience as we work to resolve this issue.
Posted Jun 12, 2026 - 11:00 UTC

Update

We identified issue preventing a subset of Sage 50 Cloud (FR) customers in France from accessing the service. We are currently investigating
Posted Jun 12, 2026 - 09:32 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 12, 2026 - 09:13 UTC
This incident affects: Europe (Sage 50 Cloud (FR)).