The issue is resolved and the service continues to perform as expected.
Posted Aug 10, 2026 - 16:11 UTC
Update
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Aug 10, 2026 - 09:10 UTC
Update
In order to introduced further stability measures we have scheduled a maintenance at 04:40 ET on the 10 of August that will last for 30 minutes until 05:10 ET on the 10th of August.
During this scheduled period customers might require to re-enter the credentials to log in or be unable to access the services for a brief period of time.
We apologise for any inconvenience this might cause.
Posted Aug 10, 2026 - 08:35 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Aug 07, 2026 - 19:43 UTC
Update
We continue to investigate the cause of the issue. If you urgently require access to your G: Drive, please reach out customers services that will be able to apply a workaround.
We apologise for any inconvenience this might cause.
Posted Aug 06, 2026 - 12:21 UTC
Update
We continue to investigate the cause of the issue. We appreciate your patience as we work to resolve this issue.
Posted Aug 05, 2026 - 19:09 UTC
Update
We are continuing to investigate the cause of the issue.
Posted Aug 05, 2026 - 17:02 UTC
Update
We have identified an issue preventing customers in the US from accessing their G drive. We are currently investigating.
Posted Aug 05, 2026 - 14:44 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Aug 05, 2026 - 14:14 UTC
This incident affected: North America (Sage 50 Cloud (US)).