Sage Final Accounts Online - Partial Outage
Incident Report for Sage
Resolved
The incident is now resolved. The service is now performing as expected.
Posted Jul 19, 2024 - 12:49 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 19, 2024 - 12:08 UTC
This incident affected: Europe (Sage Final Accounts Online).