Sage People - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Apr 15, 2025 - 15:59 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Apr 15, 2025 - 08:13 UTC

Update

We have identified an issue that is preventing UK customers from running their imports and is also causing timeouts. We are currently investigating.
Posted Apr 14, 2025 - 17:09 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 14, 2025 - 16:35 UTC
This incident affected: Europe (Sage People).