The issue is resolved, and the service is available and performing as expected.
Posted Sep 26, 2025 - 08:59 UTC
Identified
We identified an issue preventing United Kingdom customers from submitting pension data to TPP (The Peoples Pension) via PDX. We are engaged with our third-party TPP support to resolve/investigate the issue.
Posted Sep 25, 2025 - 16:33 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 25, 2025 - 16:17 UTC
This incident affected: Europe (Pension Data Exchange (UKI), Sage Business Cloud Payroll).