The issue is resolved and the service is available and performing as expected.
Posted Mar 25, 2025 - 16:24 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
If you are still experiencing issues, you may continue to use voice MFA. If voice MFA does not work, reach out to your local customer service team.
Posted Mar 24, 2025 - 15:52 UTC
Identified
We have identified an issue resulting in a subset of customers in South Africa not receiving their MFA SMS resulting in them not being able to log into the products. Products/services affected include but are not limited to:
-Sage Business Cloud Payroll Professional (ZA)
As a workaround, the customers may use voice MFA. If voice MFA does not work, please reach out to your local customer service team.
Posted Mar 21, 2025 - 11:16 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 21, 2025 - 10:32 UTC
This incident affected: Middle East and Africa (Sage Identity Service).