Home
Availability
Incident History
x
Get the
Atom Feed
or
RSS Feed
.
Sage Business Cloud Accounting ZA - Operational
Incident Report for
Sage
Resolved
The incident is now resolved. The service continues to perform as expected.
Posted
17
days ago.
Mar
14
,
2025
-
16:55
UTC
Monitoring
We have identified an issue affecting a subset of customers in South Africa who were trying to log into the service.
The issue is now restored. The service is currently performing as expected.
Posted
18
days ago.
Mar
13
,
2025
-
17:00
UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted
18
days ago.
Mar
13
,
2025
-
11:48
UTC
This incident affected: Middle East and Africa (Sage Business Cloud Accounting ZA).
×
Subscribe to Incident
Subscribe to updates for
Sage Business Cloud Accounting ZA - Operational
via . You'll receive .