Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 16:00 UTC
Scheduled
South Africa Online Tax Calculator will be undergoing maintenance on Wednesday, June 25th, 2025, for 1 hour and 30 minutes, between 18:00 SAST and 19:30 SAST.
The calculations feature will be unavailable for few minutes during this scheduled time. All other product functionality will be available and performing as expected.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Jun 24, 2025 - 14:55 UTC
This scheduled maintenance affected: Middle East and Africa (South Africa Online Tax Calculator).