Sage Identity Service - Operational

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Apr 30, 2025 - 12:12 UTC

Investigating

We have identified that customers globally are more likely to be presented with a CAPTCHA challenge when trying to log into their Sage products.

We are currently investigating and apologise for any inconvenience this might cause.
Posted Apr 29, 2025 - 11:12 UTC
This incident affected: South America (Sage Identity Service), Middle East and Africa (Sage Identity Service), Asia Pacific (Sage Identity Service), North America (Sage Identity Service), and Europe (Sage Identity Service).