We have received reports that a small subset of customers continue to experience slowness. We are investigating.
Posted Sep 10, 2026 - 15:11 UTC
Monitoring
The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Sep 09, 2026 - 23:04 UTC
Update
We are investigating an issue causing slowness for a subset of customers in the USA and Canada. The service remains available and is performing as expected for all other customers.
Posted Sep 09, 2026 - 17:09 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Sep 09, 2026 - 16:58 UTC
This incident affects: North America (Sage Intacct).