Sage RTX (EU) - Degraded Performance

Incident Report for Sage

Resolved

The incident is now resolved. The services continue to perform as expected.
Posted Apr 11, 2025 - 15:39 UTC

Monitoring

Third-party, Revenue Online Service (ROS), has confirmed that the issue has been resolved. We can confirm that our customers are successfully submitting their PSR's to the revenue.

We will continue to monitor closely.
Posted Apr 11, 2025 - 08:24 UTC

Update

We identified an issue with the Irish Revenue Online Service (ROS) preventing Irish customers from transacting with the Payroll Submission to Revenue (PSRs).

The products/services affected is:

Sage Business Cloud Payroll

We are engaged with third-party, Revenue Online Service (ROS), waiting for updates.
Posted Apr 10, 2025 - 13:22 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 10, 2025 - 13:04 UTC
This incident affected: Europe (Sage Business Cloud Payroll, Sage RTX (EU)).