Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2025 - 22:00 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Thursday, July 31th, 2025, for 15 minutes, between 01:01 BST and 01:21 BST. (10:01 AEST and 10:21 AEST). (20:01 EST and 20:21 EST on July 30th).
The service may be unavailable during this scheduled time. We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance le jeudi 31 juillet 2025, pendant 15 minutes, entre 01h01 BST et 01h21 BST (10h01 AEST et 10h21 AEST) (20h01 EST et 20h21 EST le 30 juillet).
Le service pourrait être indisponible pendant cette période. Nous vous prions de nous excuser pour la gêne occasionnée.
Merci. L'équipe Sage
Posted Jul 24, 2025 - 13:51 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).