Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2025 - 07:30 UTC
Scheduled
Sage Construction Management will be undergoing maintenance on Saturday, August 23rd, 2025, for 7 hours, between 08:30 BST and 15:30BST. (19:30 AEST and 02:30 AEST, on August 24th). (03:30 EDT and 10:30 EDT).
The service will be unavailable for few hours during this scheduled time.
We apologise for any inconvenience this may cause.
Sage Construction Management fera l'objet d'une maintenance le Samedi 23 Septembre 2025, pendant 7 heures, entre 03:30 EDT et 10:30 EDT.
Le service sera indisponible pendant quelques heures durant cette période programmée.
Nous vous prions de nous excuser pour la gêne occasionnée.
Merci. L'équipe Sage
Posted Aug 22, 2025 - 09:26 UTC
This scheduled maintenance affected: Asia Pacific (Sage Construction Management), North America (Sage Construction Management), and Europe (Sage Construction Management).