Sage Intacct - Degraded Performance
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Mar 25, 2024 - 18:07 UTC
Update
We identified an issue that may impact NA customer who use the following product features: Fixed Assets, Lister, and Import.

We are currently investigating.
Posted Mar 25, 2024 - 17:03 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Mar 25, 2024 - 16:34 UTC
This incident affected: North America (Sage Intacct).