Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 21, 2024 - 06:00 UTC
Scheduled
Sage Business Cloud Payroll International will be undergoing maintenance on Wednesday, August 21st, 2024, for 9 hours, between 08:00 SAST and 17:00 SAST.
The service will be unavailable for some hours during this scheduled time.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Aug 20, 2024 - 15:19 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Business Cloud Payroll International).