Sage.com Websites - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved and the service is available and performing as expected.
Posted Feb 16, 2025 - 05:27 UTC

Update

We identified an issue where the sage.com website will intermittently present a “Sage.com is undergoing maintenance right now”. We are currently investigating.
Posted Feb 16, 2025 - 04:49 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Feb 16, 2025 - 04:29 UTC
This incident affected: North America (Sage.com Websites) and Europe (Sage.com Websites).