The issue is resolved and the service is available and performing as expected.
Posted Sep 30, 2025 - 06:02 UTC
Identified
We identified that customers in the UK, Ireland and North America are unable to manage their subscriptions on the following products:
-Sage Business Cloud Accounting UKI -Sage Business Cloud Accounting Individual -Sage Business Cloud Accounting NA -Sage For Accountants.
All other product functionality is working as expected.
We are currently investigating.
Posted Sep 29, 2025 - 15:39 UTC
This incident affected: North America (Sage Business Cloud Accounting (NA)) and Europe (Sage Accounting Individual, Sage Business Cloud Accounting (UKI), Sage for Accountants).