Sage Business Cloud Accounting (NA) - Major Outage
Incident Report for Sage
Resolved
The issue is now resolved and the service is available and performing as expected.
Posted Jul 29, 2022 - 13:35 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 29, 2022 - 13:01 UTC
This incident affected: North America (Sage Business Cloud Accounting (NA)).