Sage Business Cloud Payroll ZA - Major Outage
Incident Report for Sage
Resolved
We have resolved a network level error and the system is operational.
Posted May 08, 2020 - 14:23 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 08, 2020 - 13:41 UTC
This incident affected: Middle East and Africa (Sage Business Cloud Payroll South Africa).