Sage Business Cloud Payroll - Partial Outage
Incident Report for Sage
Resolved
We have resolved an issue preventing customers in the UK and Ireland from accessing payroll (via support admin panel, client management, Partner edition or direct login). All other product functionality were working as expected
Posted Jun 10, 2024 - 09:53 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jun 10, 2024 - 09:44 UTC
This incident affected: Europe (Sage Business Cloud Payroll).