Sage Business Cloud Payroll International - Partial Outage
Incident Report for Sage
Resolved
The issue is resolved and the service is available and performing as expected.
Posted Jul 26, 2024 - 17:15 UTC
Update
We identified an issue where a small subset of Canadian customers' employees are not receiving direct deposits.
We are currently investigating.
Posted Jul 26, 2024 - 16:56 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Jul 26, 2024 - 16:37 UTC
This incident affected: North America (Sage Business Cloud Payroll International).