Sage.com Websites - Partial Outage

Incident Report for Sage

Resolved

The issue is resolved, and the service is performing as as expected.
Posted May 06, 2025 - 08:40 UTC

Identified

We have identified the cause of the issue and are working on a fix.
Posted May 06, 2025 - 07:57 UTC

Update

We identified that customers globally are unable to complete purchases on the sage.com website. All other product functionality is working as expected.

We are currently investigating.
Posted May 06, 2025 - 06:46 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted May 06, 2025 - 06:37 UTC
This incident affected: South America (Sage.com Websites), Middle East and Africa (Sage.com Websites), Asia Pacific (Sage.com Websites), North America (Sage.com Websites), and Europe (Sage.com Websites).