Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2025 - 08:00 UTC
Scheduled
Sage People SFTP will be undergoing system maintenance on Thursday, December 9th, 2025, for 3 hours, between 08:00 UTC and 11:00 UTC. (03:00 EST and 06:00 EST).
During this scheduled time the Sage People application will remain online, but any Pay flow using the SFTP server during maintenance may experience incomplete file transfers.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Dec 09, 2025 - 09:12 UTC
This scheduled maintenance affected: North America (Sage People SFTP) and Europe (Sage People SFTP).