Sage 50 - Product Discovery

Incident Report for Sage

Resolved

The issue is resolved and the service continues to perform as expected.
Posted Apr 22, 2025 - 19:39 UTC

Monitoring

The service is performing as expected. Avoiding a reoccurrence is our priority as we closely monitor the service.
Posted Apr 22, 2025 - 16:21 UTC

Update

We have identified an issue where Pendo messages are showing up with blank screens for US and Canadian customers. We are currently investigating.
Posted Apr 22, 2025 - 14:15 UTC

Investigating

We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Apr 22, 2025 - 13:51 UTC
This incident affected: North America (Sage 50).