Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2025 - 22:00 UTC
Scheduled
Brightpearl Europe will be undergoing maintenance on Wednesday, February 19th, 2025, for 30 minutes hours, between 22:00 UTC and 22:30 UTC. (23:00 CET - 23:30 CET).
The service may be unavailable for a short period during this time for a subset of customers.
We apologize for any inconvenience this may cause.
Thank you.
The Sage Team
Posted Feb 13, 2025 - 08:43 UTC
This scheduled maintenance affected: Europe (Brightpearl).