Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2025 - 16:00 UTC
Scheduled
Sage Business Cloud Payroll South Africa will be undergoing maintenance for 3 hours and 30 minutes, on April 9th, 2025, between 18:00 SAST and 21:30 SAST.
The service will be unavailable during this scheduled time.
We apologise for any inconvenience this may cause.
Thank you. The Sage Team.
Posted Apr 09, 2025 - 12:11 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Business Cloud Payroll South Africa).