Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 20, 2026 - 15:00 UTC
Scheduled
Sage Portal will be undergoing system maintenance on Friday, February 20th, 2025, for 7 hours between 17:00 SAST and 00:00 SAST on February 21st. (02:00 AEDT and 09:00 AEDT on February 21st).
The service will be unavailable during this scheduled time.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Feb 19, 2026 - 15:39 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Portal) and Asia Pacific (Sage Portal).