Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 18:00 UTC
Scheduled
As part of our commitment to security and delivering the best possible customer experience, Sage Business Cloud Accounting ZA will be undergoing maintenance on Wednesday, March 5th, 2025, for 2 hours, between 18:00 SAST and 20:00 SAST.
As part of this update, all users will be logged out. You will be able to log back in again shortly afterwards and this is nothing to be concerned about.
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Mar 05, 2025 - 09:56 UTC
This scheduled maintenance affected: Middle East and Africa (Sage Business Cloud Accounting ZA).