Companies House Service (CHS) - Degraded Performance

Incident Report for Sage

Update

Companies House is continuing to investigate the issue. We appreciate your patience and we will let you know as soon as this issue is resolved.
Posted Jun 15, 2026 - 16:07 UTC

Identified

We have identified degraded performance impacting customers in the UK. Users are experiencing delays when processing filings, with submissions remaining stuck in a “sent” status in Companies House.
We are waiting for Companies House updates.
Posted Jun 12, 2026 - 16:01 UTC
This incident affects: Europe (Companies House Service (CHS)).