Completed
The scheduled maintenance has been completed.
Posted Aug 17, 2025 - 00:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 16, 2025 - 21:00 UTC
Scheduled
Multiple products/services will be under scheduled maintenance on Saturday, August 16th, 2025, for 3 hours, between 21:00 UTC and 00:00 UTC, on August 17th.
The below product/services maybe be impacted:
• Sage Business Cloud Accounting - Sage Intelligence
• Sage People
• Subscription Services
• Sage50c - Sage Intelligence
• Customer Community
• Application Registry
• sage.com (cart will be unavailable)
• Sage for Accountants
We apologize for any inconvenience this may cause.
Thank you. The Sage Team
Posted Aug 08, 2025 - 12:42 UTC
This scheduled maintenance affected: Middle East and Africa (Application Registry, Sage.com Websites, Sage People), Asia Pacific (Application Registry, Sage.com Websites, Sage People), South America (Application Registry, Sage.com Websites, Sage People), Europe (Application Registry, Customer Community, Sage.com Websites, Sage50c - Sage Intelligence, Sage Business Cloud Accounting - Sage Intelligence, Sage for Accountants, Sage People, Subscription Services), and North America (Application Registry, Customer Community, Sage.com Websites, Sage Business Cloud Accounting - Sage Intelligence, Sage for Accountants, Sage People, Subscription Services).